[symfony 1.4] Class ‘sfLoader’ not found

Sollte man mal eine symfony 1.2.x Anwendung auf symfony 1.4.x migrieren und man stößt auf diesen Fehler:

Class 'sfLoader' not found

Dann hat man versucht einen Helper in der Action zu laden zB so:

sfLoader::loadHelpers('String');

Der sfLoader ist in 1.4 allerdings entfernt worden.
Stattdessen sollte man dann sowas schreiben:

$this->getContext()->getConfiguration()->loadHelpers('String');

Dann klappts.

Leave a Reply

Your email address will not be published. Required fields are marked *